Memsource/Phrase issues

Is it only me or does Memsource/Phrase have a lot of issues lately? (I’ll update this post with issues as I come across them) During the past weeks I have worked on several TWB projects and I keep encountering issues that keep delaying me.

  • Preview doesn’t work, so I have to go online and find the original source text, since Romanian is a gendered language and if there is text describing an image I need to know if I have to use the feminine or the masculine of the noun/pronoun/adjective/etc.
  • the CAT pane is blank, so if I have segments with the same/similar source text, I have to type the text in each of them. In the past, after translating and confirming one segment, when I would get to the other segment(s), a suggestion with that segment would be in the CAT pane, so I would just click on it and confirm the segment.
  • Segment confirmation button doesn’t always work. In some files, when I try to confirm a segment after typing the translation, a message would pop up: ”Saving segment #201 on the server has failed.". And no strategy works: deleting and typing again, refreshing the page, closing & reopening the browser or even the laptop.
  • Complete button doesn’t work - After I made sure all the segments were confirmed and I ran the QA, I clicked the Complete button and everything seemed to be as usual. But later when I checked my Claimed Tasks tab from the TWB homepage, the task was still in my list, with the Complete button greyed out. All segments confirmed, QA ran and the button still greyed out.
  • I received an email from TWB about successfully submitting a task - I thought it had been completed 2 days ago. All segments confirmed, QA ran, Complete button worked and the task wasn’t under my In Progress Claimed Tasks anymore.

I don’t seem to have any issues with connectivity, the browser or the other programs on my laptop. MemoQ works just fine.

So, I am curious, is it only me, or is this a general issue with Memsource/Phrase?

Hi @ElenaF !

How are you today? I hope things are going well. My name is Manuel, part of the TWB Staff. Nice to meet you :slight_smile:

Thanks for sharing your feedback. I’d be interested in looking into it together and see if we can narrow down the problems so I can report them to Memsource/Phrase.

  1. Preview issue: I suspect you’re experiencing this with translations of IDML files. Is that possible? This is a known issue with the system, and we’ve reported it multiple times. There is a pending feature request that was created because of our complaints, but overall it’s a problem they need to address. I’ll report again to see if we can do anything to push on this more!
  2. Blank CAT Pane: this one is strange… can you point me to a specific task in which you experienced this? I’d love to take a look
  3. Segment confirmation button: There are a number of things that can cause this. Can you share a specific task in which this happens? When we’ve reported it in the past, we were told this is caused by connection problems, but for a long time we’ve suspected that there’s a bit more to it than that. Give that you mention you work with other CAT tools like MemoQ, have you ever experienced issues like this one with it? :slight_smile:
  4. Task complete button: again, same as before. Any specific task I can look at?

I must say we share your frustrations regarding the recent unexpected changes to the system (took us by surprise as well). We’re doing our best to try to make your volunteering experience as enjoyable as possible. Again, thanks for taking the time and writing all this feedback. We genuinely appreciate it.

Wishing you a great Friday,

1 Like

Hello Manuel, nice to meet you too! :slightly_smiling_face:

Thank you for your help! I’ve contacted Memsource/Phrase support too, since my frustrations with the CAT tool grew and grew. Basically, they said that they can’t pinpoint the exact issues, but that it’s best to download their Desktop Editor and work on the tasks there, rather than in the Web Editor. So far, so good. Except that I have just encountered another problem: in order to work on the file in the Desktop Editor, one needs to download the .xliff file from the Web Editor and the whole page (and browser!) freezes so I can’t click on anything. It’s an IDML file (4.2 Hopefully Healthy Happy Living Toolkit Activity Guide – Psychosocial Support (PSS) for teachers, parents, caregivers.idml), so my approach now is to open the file in the Web Editor and leave it for a few minutes, then try to download it.

  1. Yes, one of the files with the preview issue was IDML, namely happy_healthy_living_guide for teachers.idml. It was a revision task. But I had the same problem with another type of file, XLSX, for this revision task: Phase 1 UFAA Content for Translation __ Clear Global.xlsx.
  2. Actually, the latter, Phase 1 UFAA Content for Translation __ Clear Global.xlsx, was the main source of my frustrations, since that one had the blank CAT Pane. It is a First Aid guide and has instructions (which are similar) for different age groups. So, after revising the bit about providing first aid to adults, I came across the section regarding children, and I had expected to see suggestions for segments from within the file (to ensure consistency of similar wording), but the pane was blank for most of the segments.
  3. The file where I couldn’t confirm the segment was a translation task: 3.2 Say No To Sexual Misconduct Presentation.pptx. This is when Memsource/Phrase support instructed me to download the Desktop Editor, open the file and confirm the segment there. And that worked.
  4. Now, this one is tricky because I usually delete emails once they’re no longer relevant (and empty Trash at the end of the day), and I’ve worked on several tasks in the past week. Looking through the Claimed Tasks > Completed list, I think it may be one of the 3 New provide help.xlsx files, but I’m not sure at all. All I remember is that I was working on the UFAA file when I received the email about completing a task, which was odd because they usually come within a minute of submitting the task. And that day I hadn’t submitted anything. I checked that task at the time and it was something I had worked on.

I haven’t been using MemoQ for a long time, but no issues there yet :slight_smile:

I know you’re all working hard to make things run smoothly and I really appreciate all the friendliness and support I’ve received from TWB.

Enjoy your weekend,

Hello Manuel,

I am having issues with Phrase again.

  • With the task 7 How to set up and manage a Community-based Complaints Mechanism.docx: On the web editor, after I confirmed all segments and ran QA, the “Complete” button was still not active. I downloaded the .mxliff and opened it in the desktop editor and that way I was able to click on the “Complete” button. Still, half an hour later I still haven’t received the confirmation email (they usually come within a minute). In the Claimed Tasks feed on the TWB platform is under the “Completed” tag, so I guess it did register as complete.
  • With the task 2 MAI-TEACHERS-GUIDE-2022-04-07.idml: There a few segments in the introduction which mention the titles of the job positions of the authors and their places of work and this is the same text I had revised in another file, (NEW)_COVER-Magnificent Mei Comics.idml. I was hoping to find it in the CAT pane, to save time researching this information again.

Here are screenshots from the web editor

and the desktop editor

The CAT pane is blank in both of them. This is the case with most of tasks I have worked on lately in the web editor (and sometimes the confirm segment function not working), but now not even the desktop editor works properly.

I know the issues are with Phrase, not TWB, but I just wanted to flag them, so that you guys are aware of them.

Enjoy your weekend,