Can't access memsource

I claimed a task, then I clicked “Translation URL”.
Memsource pops up in a new browser tab, but it says: “Sorry, we were not able to find a user for you. Please contact your System Administrator.”
I tried with different browsers and still nothing.
I’ve never had issues with working on my tasks before and I am unsure of how to resolve this matter. Anyone know how to fix this issue?

1 Like

Hi @nameisoyl

I’m sorry to hear you’re having difficulties accessing Memsource!

Your login with Memsource is directly related to the TWB Platform, so once you claim a task you will be able to access that task in Memsource by following the available links! You won’t need to login and don’t need to set up a password :+1:

But if you’re struggling to login, please click on the Memsource link and then click on the SSO (Single Sign On) button and enter “twb”. This should help you log in!

Don’t hesitate to reach out again if it doesn’t work :slightly_smiling_face:

1 Like

Hello, I hope you are doing well.

How can I recover my login details for Memsource? I have tried the “recovery password” button, but after entering my original username, I don’t receive the recovery email. I have also tried using my email address, but no luck.

Thanks in advance!
PS: I have finished revising a document and was trying to submit it. So these is some urgency in this request.

1 Like

Hi @Palvares

Memsource is directly linked with the TWB Platform, so you don’t need a login for Memsource! You can access the task by following the link in the project description :smiley:

I’ve moved your post to this thread where other linguists have had issues logging into Memsource.

Thanks for your support on the project, Pedro!

2 Likes