UA - apostrophe typing problem in Memsource

Hello, I would like to report a small typing problem noted in Memsource (Ukrainian language).
There is a symbol of apostrophe used in the Ukrainian words, which should look like ’ and is typed using the key ~\ˋ in the Ukrainian keyboard layout.
In Word, on other platforms including this comment window, it works perfectly.
But when typing in Memsource, the symbol is actually typed as " (so, double apostrophe instead of single one), which is not right.
Thereby, to get the needed symbol in the text, I have to type the word elsewhere, and then copy-paste it to memsource.
If there is a way to control and fix it, it would help to save a bit of our time.
Example of a Ukrainian word with apostrophe (if helpful): “пам’ять”

Thanks.
Olena.

1 Like

Hi Olena! As you rightly said, Memsource actually type apostrophes in a different way from other apps/programs even in other languages. What can be done in this case is pressing “Shift” along with apostrophe button, or enabling “caps lock” when typing the apostrophe. Hope this works for you when you claim your next task :orange_heart:

Do let me know if you need any further assistance :dizzy:

1 Like

Hi Aya! I am sorry for such a delay of response, but it happened to me to come across this problem only now, again. I’m afraid it persists, and the trick with “Shift” or “Caps lock”, as per your kind advice, doesn’t work unfortunately.
Furthermore, I opted to use “insert symbol” function offered by Memsource, and insert this apostrophe from Latin symbols. Then I tried shifting to English on my PC keyboard, and type the usual English symbol '. In both cases, the symbol is shown as " in target text on Memsource, because probably it is inside a Cyrillic digital ambient that goes in conflict with standard Latin script. My third try was again with Memsource’s function “insert symbol”, but this time I chose “Cyrillic symbols”, and it worked perfectly! The trouble is, this way is quite laborous, so I came back to the option as in my first comment.
Well, maybe other users have the same problem? If so, it is just to report to Memsource managers, so that they can check and eventually correct their software.
Thanks a lot for your attention,
Olena.

Hi Olenka,

Thank you so much for your feedback on this and no worries at all, your feedback is appreciated at all times.

Is only proper to start by Introducing myself, my name is Ahmad Ali Saleh and i am the community officer for TWB_Ukraine response. Aya is my colleague, and she now works in a different capacity with us.

Thank you again for your explicit feedback, we would look into this and get back to you as soon as possible.

Ahmed.

3 Likes

Hello Olenka!

It’s nice to e-meet you. Ahmed told me about the issue you’ve been having and asked me to check if it was the same for me (I also work in Ukrainian). Here’s what I’ve found:

Memsource allows translators to customize the quote and apostrophe types in source and target. The default option is set to quotation marks for both the quotes and the apostrophe. But we can change that. In order to do so, please follow these steps:

  1. When working in the Memsource editor, click “Format” on the panel above.
  2. In the drop-down menu, move your mouse to “Quotation” and then to “Target”
  3. Select the option «quote» apostrophe’
  4. After this, you’ll be able to type the apostrophe by pressing the ~ key.

I’m also attaching the screenshot.

Please let us know if this works, and feel free to ping me if you need any further help with this.

Have a great day!

2 Likes

Hi Lisa,
Nice to meet you, too.

I have tried your solution right now, and it worked! I imagined there should have existed a trick like this, but wouldn’t have managed to arrive to it on my own.

So, thank you @lisa.bolotova and @AhmedAliSaleh Ahmed very much for a very prompt reaction, this for sure will help me to work better :blush:

Have a very nice day,
Olena.

1 Like

Hi Olenka,

Glad to hear your issue is solved, thank you for your great contribution. Always happy to support.

1 Like