Memsource bug


I’ve been trying to work on my first revision task. However, every time I click on a column or the text itself, my screen freezes and the program is not responding. I’ve used various devices, tried accessing it in different browsers and through separate links (TWB profile and the e-mail one) but to no avail. The deadline is approaching, I’m at my wit’s end because I can’t figure out what the issue might be.

Can someone help me with this?


Could you please advise if this issue remains? If that’s the case, could you please advise the corresponding project name/number?

Kind regards,

The issue has been resolved but thank you for reaching out!


HI @maria.swiatlon!

I have the same issue as well. I have tried to restart my pc several times, I have updated all my software and I have even tried to free up some RAM space by uninstalling some of the useful programs on my pc but the issue persists. Could you advise me on what to do, I will greatly appreciate it.


Thank you for your message.
Please let me check it with our Tech Team :slight_smile:
Kind regards,

HI @Igera !

Thanks for reaching out and thanks for taking all those steps to try to fix the issue. Could you please let me know exactly which task from the ones in your profile you are struggling with? I see you have eight tasks in progress.



Try doing what I did: as soon as the page loads, click on Tools → Preview → Disable.
Hope it helps!

Hi @Manuel!

Please note that the tasks I am struggling with are those that need to be translated into Swahili.

Hi @liviad !

I have tried that tip but it still does not work.

Thanks @Manuel! The issue has been fixed :+1:

1 Like