How to open a translation or revision task in the Phrase TMS Web Editor

Hi @millanberry

I can confirm what the kind @faretto5 has said, that the translation for the Chunk hasn’t yet been completed and so you are not able to access the link to revise the text!

Once the translation has been completed, you’ll receive an email inviting you to start revising the Chunk :email: :+1:

Please don’t start the task until you receive this email because otherwise you could start revising the Chunk before the translation has finished translating.

Thanks for your support on the project, Manal :smiley:


Thank you Charlotte for your clarification, yeah
now I’ve got the message.

1 Like

Thank you a lot faretto5

1 Like

your answer is very helpful so thank you a lot faretto5

1 Like

I have claimed a task to translate, but when I click on “Translate using Memsource” it leads me to a page where it says “Sorry, we were not able to find a user for you. Please contact your System Administrator”. What should I do?
Thank you

Hi @sarasilva !

We are currently investigating an issue with the login subsystem of Memsource and TWB Platform. We are doing our best to have it back up and running as soon as possible!

I just checked in the system and I think the issue with your account should be resolved. Could you please confirm that you are now able to access Memsource on your end? You can check this by clicking on the “Translate in Memsource” button in your Claimed Tasks section in TWB Platform.


1 Like

The task with which I was having issues has now disappeared from my “claimed tasks” tab.
I have another one that I had claimed and it is working fine.

Hi @sarasilva

I’m glad to hear that you were able to access the new task on Memsource! Sorry for any inconvenience with the previous task :slightly_smiling_face:

I’m pinning @Manuel to keep him in the loop!

1 Like

Hi, I hope you are doing well. I am new here and I want to ask when can I be able to claim tasks/projects, I see the lock sign for each project ,what does this mean?


Hello @Fadia1 and welcome to TWB!

I can confirm that your profile is complete, and that the language pair English to Arabic is listed in your profile :white_check_mark: This should make you able to claim tasks in this language pair :+1:

You can refer to this thread to learn how to find and claim tasks :smiley:

Also, you may find it useful to take a look at the Translator’s Toolkit to learn more about TWB Platform :toolbox:

Remember that the homepage only shows tasks available at the time you are looking :eyes: If you cannot see any tasks in your language pair, don’t worry. We post new tasks all the time, so keep an eye out! :wink:

I hope this helps! Please let us know if you have any questions :sunflower:

1 Like

Hi @Aya.Alrifai @ClaudiaM,
I am having problems with Memsource. A couple of days ago, I have claimed 4 tasks but, until now, I have not been able to translate any of them because any time I click on ‘translate using Memsource’ the page is blank.
What can I do?

Thanks in advance,


P.s. the tasks’ deadline is tomorrow 04/02

Hi @Alex9 and thank you for reaching out!

I believe that everything is working fine now, could you please confirm that the tasks are accessible for you?

1 Like

Hi @Aya.Alrifai thank you for your reply.

Yes, I’ve been able to complete the tasks, even if I had to do it past the deadline.
I hope that in the future, I won’t have problems with Memsource again.

All the best,


Hi @Alex9

Apologies for what happened, but don’t worry as the issue surely wasn’t from your side :pray:

Thank you for completing the tasks :sunflower:

1 Like

Hi @Aya.Alrifai

No worries :smiley: We all know that, sometimes, technology can give us headaches :roll_eyes:
Luckily I’ve been able to complete the tasks without that much delay :v:

Have a great weekend :sunny:

1 Like

A post was merged into an existing topic: CARE Program Strategy Resource Manual 29593

Dear Community, I am new to the platform and have troubles accessing Memsource for my first task. I have followed the instructions above, but the page keeps loading at 73%. I was wondering, if someone had a similar problem and knows a possible solution? I have already tried using different internet connection (thought it might be a firewall), but still no luck. Would appreciate any hint!

Hi @varenik.psih and welcome to our community!

I see that you could successfully access the task and translate it :100: Mostly the problem takes place due to unstable connection, but if this is not the case, I would recommend trying to access Memsource from a different browser, Google Chrome can be a good option for this :woman_technologist:

If you need any further assistance, please don’t hesitate to contact reach out :innocent:

Thanks for your support @Aya.Alrifai !
Indeed, seems like the pc I was using has some troubles - using another one helped. Everything has worked out well now and I was able to complete a couple of tasks already.

1 Like