Where to find my claimed tasks?

Hello Everyone!

So I claimed my first task here, but I can’t find it anywhere. There is no (claimed task) option on the bar (between home and profile). I would appreciate your help! I closed the browser before I clicked on (Translate using Memsource), so how can I find the task I claimed and start translating it with the TWB Memsource account? Because I have to use the Memsource TB for this task

Thank you!


1 Like

Hi, @Areej91!

That’s strange. Have you tried to clear all cookies and cache in your browser?


If that doesn’t help, check your email and click on the task from there. Please, say that you didn’t delete the email. :pray:

Have an awesome week! :smiley:


Hi @Areej91, :raising_hand_woman:

That’s quite strange! :thinking: But If you couldn’t find the task claim notification email, I would like to suggest that if you still remember the name of the task (you can also check the ‘New’ and ‘Latest’ sections in the community), then try to find its thread and reach out to the project manager who will definitely assist you.

I hope this is helpful and if not, I am glad to help by mentioning our kind, @Silvia_Mauri :hibiscus: who will definitely help you better.

Have a great day! :sparkles:

Best regards. Lilav.


Hi @Areej91 and welcome to TWB! :orange_heart:

And many thanks for the kind @Lilav_Alarashi and @PauloRibeiro for their help :sunflower:

I checked your profile and I’m afraid that I didn’t find any tasks claimed by you :confused:

Kindly note that there is a specific process to be followed for claiming tasks. You can take a look at this thread to find out more about this process :innocent:

As for not finding the “claimed tasks” section on the homepage, this happens when you’re logged out, so if you login again, you’ll find it :+1:

Also, you may find it useful to check our Translator’s Toolkit :toolbox: to learn more about TWB Platform

Thank you Areej for your interest in supporting us! :star2:


Hello Aya
Hello Lilav and Paulo

Thank you all for your kind replies

I checked the thread you sent me Aya and I did take all the steps mentioned in the video, I even promised I will do the task! That’s why I thought the task would have been allocated to me. However, I did not receive any email for the task, which I found out about through the lovely people’s comments.

Anyway, so I was worried about not being able to deliver the translation on time because I can’t find it! But I guess this is all cleared up!

Aya, even though I logged out and in and even closed the browser many times, I still can’t find the (claimed task) section. Does it only appear if I had claimed tasks?

Thank you all again! Have a nice day


@Areej91 I’m sorry about the issues you’re facing :worried:, actually, the “claimed tasks” button should always appear as long as you’re logged in :confused:

Would you please try this link and tell me whether you can find the claimed tasks section?

Hello Aya

Thank you for the link! It worked, as in I can see that there are no tasks available.

Maybe something went wrong during the registration process? It could be that I am not registered as a translator or maybe there was something I needed to do which I might have missed?

Where would I be able to access this claimed tasks page in the future?
I’ll send a screenshot of what appears on the bar when am logged in

I believe this was happening because you were trying to access the website from the mobile :eyes: Also, this can happen if the browser you’re using is of an old version.

Are you able to access the website from a laptop? It will be much easier for you to claim tasks and work on them :desktop_computer: :innocent:

1 Like

Dear Aya

Thank you very much for you reply and help
But I logged in from the laptop, and it’s still the same. Chrome is also up-to-date and is automatically updated.

Do you think I should cancel my account and re-register?

Hi, @Areej91!

I don’t think that it would solve the problem.

I am not a specialist, but have you tried to login in another browser?

And, just in case, is your JavaScript enabled? See this.

Also, you can read this and this.

And don’t forget to tell us if it worked. :wink:


Dear @Areej91 It’s my pleasure to help :white_flower:

I’m not sure this time why the “claimed tasks” button still doesn’t appear :confused: Maybe you can try @PauloRibeiro 's solutions and see if it works (many thanks Paulo! :smiley:).

If it all doesn’t work, I suggest copying the link I included in my previous reply, and keeping it as a bookmark. Also, You may have it automatically after you do claim tasks :innocent:

Hope our solutions work for you. Let us know if you need any assistance :orange_heart:


Hello Paulo

Thank you for the links! They sadly didn’t work
I even tried on a different laptop and different browsers but no luck

I guess I’ll just comply the link Aya sent me and hope it’ll work itself out by the next update :sweat_smile:

1 Like